Audials 2019 schneidet die Songs nicht korrekt

Kommentare

167 Kommentare

  • Offizieller Kommentar
    Avatar
    Iosif Calianco

    Hallo zusammen,

    Wir haben gute Neuigkeiten! Das Problem, dass Audials Spotify-Aufnahmen nicht richtig trennt, ist behoben. Starten Sie bitte Audials neu, damit die neue Streaming Service Version 3.2.6000.0 installiert wird.

    Wir möchten uns nocheinmal für die Unannehmigkeiten entschuldigen, und wir bedanken uns für alle erteilten Informationen, die uns in der Recherche und Lösung weitergeholfen haben.

    Mit freundlichen Grüßen,
    Alexandra Mot
    Audials Support Team

    Aktionen für Kommentare Permalink
  • Avatar
    Oxenkopf1971

    Das Problem habe ich schon seit Anfang November mit Spotify ... Der Support sagte mir, dass hierfür wohl im moment keine Lösung für das Problem zu finden ist.

    Bei mir sind es bis zu 15 Sekunden, welche falsch geschnitten sind.

    0
    Aktionen für Kommentare Permalink
  • Avatar
    Starfox

    Ich setze aktuell die Songs einzeln in die Warteschlange, aber das kann es ja auch nicht sein, wozu hab ich dann Audials kann ich auch einen x beliebigen Audiorecorder nehmen.

    Kennt einer ne ältere Audials Version wo das noch funktioniert hat ?

    Von mir aus auch ohne das HighSpeedDubbing.

    0
    Aktionen für Kommentare Permalink
  • Avatar
    coffeebug

    I am having the same issue as well bad enough that I uninstalled 2019 and went back to 2018

    0
    Aktionen für Kommentare Permalink
  • Avatar
    Starfox

    Does it work in 2018 ?

    0
    Aktionen für Kommentare Permalink
  • Avatar
    JackON

    Kann mich nur anschliessen.

    Audials One 2019 ist so was von daneben.

    Die Audio Funktion ist einfach nicht zu gebrauchen.

    Weder korrektes schneiden, noch akzebtables Taging geht.

    Hab jetzt RECORDIFY getestet. Hat zwar keine HIGHSPEED Funktion und geht auch nur mit Spotify im Webbrowser, aber es schneidet richtig, fügt das korrekte Album Cover ein und tagt auch richtig. Sogar mit laufenden Nummern 01, 02, 03 usw.

    Langsam frag ich mich, was mich dazu gebracht hat, Audials zu kaufen. Kaum Updates. Und wenn was kommt ist es das gleiche wie davor. Keine Ahnung was man sich hier in der GF Ebene denkt. Und ein solches Produkt hat ja nicht mal Beta Status und sollte im besten Fall KOSTENLOS zum testen angeboten werden. Aber dafür auch noch Geld nehmen ist schlicht weg eine bodenlose Frechheit!

    WO sind die versprochenen Funktionen für die ich bares Geld hingelegt habe?

    Von SKY mal ganz abgesehen.

     

    1
    Aktionen für Kommentare Permalink
  • Avatar
    Oxenkopf1971

    @JackON Mit Recordify hast Du aber (glaube ich) über den Webbrowser nicht die HighQuality (sofern du Premium hast). Diese gibt es (wie gesagt, glaube ich) nur direkt über den SpotifyClient (eben bei Premuim).

     

    0
    Aktionen für Kommentare Permalink
  • Avatar
    woof

    @Oxenkopf1971 – Genau richtig, bei Spotify braucht es für gute Qualität den Desktop-Client. Das hält mich auch noch von der sofortigen Flucht ab...

    0
    Aktionen für Kommentare Permalink
  • Avatar
    Oxenkopf1971

    @woof Danke für die Bestätigung

    Es gibt ja auch noch andere Alternativen habe ich festgestellt, die komischerweise viele auf -FY enden...das finde ich voll SIDI !

     

    0
    Aktionen für Kommentare Permalink
  • Avatar
    woof

    Bei denen bin ich mir nur nicht sicher, ob die tatsächlich legal sind...

    0
    Aktionen für Kommentare Permalink
  • Avatar
    Oxenkopf1971

    @woof Warum legal? Die machen auch nichts anderes wie z.b. Tunebite. Abspielen und aufnehmen, aber halt auf eine andere art (würde ich mal behaupten). Und "legeal" ist immer relativ. Egal wie es ist, es immer eine Grauzone.

    0
    Aktionen für Kommentare Permalink
  • Avatar
    woof

    Bei Recordify stimme ich Dir zu, bei den anderen Alternativen, die ich so gefunden habe, eher nicht. Habe sie aber auch nicht probiert. Den Websites folgend scheinen die schon direkter auf die Streams zuzugreifen (man zieht Playlisten per Drag&Drop in die Software und dann werden die „konvertiert“, „20x speed“, ...). Da steht sogar „With an innovative DRM decrypting technique“ – das wäre, wenn mehr als Marketingsprech, zweifelsfrei nicht rechtskonform. Noch dazu fehlen den Websites durchweg Adressen, echte Kontaktdaten usw. Nein, m.E. ist Audials keine Grauzone, ggf. verstößt man gegen die AGB, aber die Privatkopie ist dennoch – aus meiner Sicht als Nicht-Jurist – legal.

    0
    Aktionen für Kommentare Permalink
  • Avatar
    Oxenkopf1971

    Nun...mit den 20X gebe ich dir schon recht, dass da was nicht korrekt zugehen kann. Legal, illegal, Grauzone: Eigentlich hier jetzt egal! Fackt ist, das TB nicht korrekt schneidet.

    BTW: Ich hatte mal einen Track bei Spotify ausgesucht, in dessen waren 2 Lieder (sollte eigntlich nur eins sein), mit ca. 3 Sekunden Pause dazwischen. Dieser Track wurde nicht geteilt (wie man hätte annehmen müssen), sondern die zwei Titel (in einem Track) wurden an einem Stück aufgenommen! Also orientiert sich AUDIALS wohl NICHT an der Stille in Liedern, sondern es muß ein anderes Verfahren sein!

    Ich wwerde nachher mal den Track raussuchen

    0
    Aktionen für Kommentare Permalink
  • Avatar
    audials_guy

    Hallo Oxenkopf, hallo Starfox, hallo Woof,

    wir bei Audials bemühen uns eine "perfekte Spotify-Aufnahme" zu bieten, daher nehmen wir diesen Fehler unter dem ihr offenbar leidet sehr ernst.

    zum Aufnahmeverfahren:

    Tatsächlich berücksichtigt Audials neben Stille auch die Ausgabe von Spotify beim Abspielen. So vermeiden wir ziemlich zuverlässig, dass Lieder fälschlich "in zwei Teile" zerschnitten werden.

    Was Oxenkopf hierzu berichtet, stimmt also und ist Absicht.

    zu Updates:

    Wann immer wir etwas an der Aufnahme verbessern können, veröffentlichen wir kostenlose Updates.
    Diese kann man hier sehen 

    https://support.audials.com/hc/de/sections/115000239909-Release-Notes

    die Spotify betreffenden Updates heißen "Streaming Service" und werden automatisch beim nächsten Audials-Start automatisch installiert.

    zum beschriebenen Fehler:

    Aber zum eigentlichen Thema:

    Der Beschreibung entnehme ich, dass insofern falsch geschnitten wird, dass in einem Lied am Ende der Anfang des nächsten Liedes "mit drin steckt". Audials hätte also den Schnittpunkt "zu spät" gesetzt.

    Das sollte auf keinen Fall passieren!

    Während es unter bestimmten Umständen bei bestimmten Nutzern auftritt (z.b. eben bei Euch), schneidet es bei den allermeisten Nutzern eben durchaus perfekt.

    Wir haben etliche Tests gemacht (gerade eben habe ich "sicherheitshalber" auch noch mal probiert), und können diesen Fehler bisher einfach nicht reproduzieren, nicht sehen. Ohne es zu sehen, lässt sich aber keine Abhilfe programmieren...

    Daher meine Bitte, ob ihr evtl. mithelfen könntet, etwas besser einzugrenzen WIE man diesen Fehler erzeugen kann.

    Frage zum System:

    - Welche Windows-Version? (7, 8, 10, insbes: 64bit oder 32bit?)

    - CPU, Arbeitsspeicher?

    - herkömmliche Festplatte oder SSD?

    - Welche Spotify Version?

    - Spotify "aus Windows Store" oder "selbstinstalliert"?

    - Spotify free oder Premium?

    - Wie ist die Lautstärke von Spotify gesetzt?

    - Ist in Spotify-Einstellungen "Standardeinstellungen - gleiche Lautstärke für alle Songs festlegen" an oder aus?

    Frage zu Randbedingungen des Fehlers:

    - Tritt der Fehler nur bei "High speed" auf, oder auch bei Normalgeschwindigkeit?

    - Tritt der Fehler immer (bei jedem Lied) auf, oder nur sporadisch?

    - Tritt der Fehler in jeder Session (in jedem Durchgang) auf, oder nicht?

    - Ist der Fehler - um wie viele Sekunden verschoben ist - dann in allen Liedern gleich, oder variiert er?

    - Ist er vielleicht "lastabhängig", d.h. wird er häufiger wenn man auf dem PC "andere Dinge tut"?

    - Hängt er vielleicht von den Lieder ab, d.h. tritt bei bestimmten Liedern immer auf? (Dann wäre natürlich super zu wissen, welches Lied)

    - Gibt es, falls dieser Fehler auftritt, in der gleichen Session (Durchgang) auch Tagging-Fehler dass entweder "Künstler" oder "Liedname" fehlen würde oder nicht korrekt wäre?

    - Gibt es irgend etwas Sonstiges an "Umständen", die diesen Fehler auslösen oder häufiger machen?

     

    Es tut mir leid, dass ich Euch mit "so vielen Fragen löchere". Und es könnte auch an etwas ganz anderem liegen ...

    Aber es wäre einfach sehr schön, wenn es mir gelänge den Fehler zu sehen zu bekommen. Denn ich bin recht zuversichtlich, dass wir ihn dann auch beheben könnten.

     

    0
    Aktionen für Kommentare Permalink
  • Avatar
    Oxenkopf1971

    @audials_guy Ersteinmal vielen lieben Dank wieder einmal etwas von Dir zu hören. Ich habe die Fragen hier beantwortet!

    Ferner habe ich auch aktuell eine Session mit 327 Titeln am aufnehmen, welche ich nach Ende gleich mit AUDACITY sichten werde. Danach kann ich dir noch ein genaues Schnittergebnis mitteilen und dir auch gerne die Playlist teilen!

    Frage zum System:

    - Welche Windows-Version? (7, 8, 10, insbes: 64bit oder 32bit?)

    Windows 10 1809 (17763.316) 64bit, frisch aufgesetzt, alle Treiber aktuell

    - CPU, Arbeitsspeicher?

    - herkömmliche Festplatte oder SSD?

    HP-Notebook

    - Welche Spotify Version?

    1.1.0.237.g378f6f25

    - Spotify "aus Windows Store" oder "selbstinstalliert"?

    von Spotify direkt geladen

    - Spotify free oder Premium?

    Premium mit HQ-Einstellung

    - Wie ist die Lautstärke von Spotify gesetzt?

    anschlag Maximal

    - Ist in Spotify-Einstellungen "Standardeinstellungen - gleiche Lautstärke für alle Songs festlegen" an oder aus?

    AN und auf NORMAL, da eine ausgeschaltete Option die Aufnahmen schlicht und ergreifend übersteuern.

    Frage zu Randbedingungen des Fehlers:

    - Tritt der Fehler nur bei "High speed" auf, oder auch bei Normalgeschwindigkeit?

    Habe nur Highspeed getestet

    - Tritt der Fehler immer (bei jedem Lied) auf, oder nur sporadisch?

    Sporadisch, keine struktur erkennbar

    - Tritt der Fehler in jeder Session (in jedem Durchgang) auf, oder nicht?

    Generell ja. Ich bin überzeugt, dass wenn man eine Session zweimal aufnimmt es immer sporadisch dann einen anderen Titel trifft.

    - Ist der Fehler - um wie viele Sekunden verschoben ist - dann in allen Liedern gleich, oder variiert er?

    Unterschiedlich. Mal ist der schnitt um 10 Sekunden, mal um 16 Sekunden verschoben. Teilweise aber auch nur Milisekunden, wo der Schnitt einfach nicht passt.

    - Ist er vielleicht "lastabhängig", d.h. wird er häufiger wenn man auf dem PC "andere Dinge tut"?

    Wenn Tunebite läuft wird daran nichts gearbeitet um Störungen zu vermeiden. Allerdings habe ich Kaspersky FREE welcher gerne mal Updated. Aber hier habe ich auch schon ein Ausschalten des Vierenschutzes versucht, keine Besserung dadurch!

    - Hängt er vielleicht von den Lieder ab, d.h. tritt bei bestimmten Liedern immer auf? (Dann wäre natürlich super zu wissen, welches Lied)

    Nein, ein fehlerhaftes Lied wird in einer anderen Session korrekt geschnitten.

    - Gibt es, falls dieser Fehler auftritt, in der gleichen Session (Durchgang) auch Tagging-Fehler dass entweder "Künstler" oder "Liedname" fehlen würde oder nicht korrekt wäre?

    Nein

    - Gibt es irgend etwas Sonstiges an "Umständen", die diesen Fehler auslösen oder häufiger machen?

    Keine Ahnung. Wie gesagt, es wird während der ganzen Session nichts daran gemacht, um sämtliche Störfaktoren auszuschließen

     

    Anmerkung: Ich habe schon folgendes versucht: Kein MP3 sondern WAV Aufzeichnung, Download der Titel in Spotify, den Aufnahmeordner auf ein Externes Medium (USB3 WD Elements HDD) verschoben. Vierenscanner deaktiviert. Alles brachte keine Besserung.

    Ich bin der festen Ansicht, die Probleme haben mit

    Streaming Service 3.1.64900.0 (2018-10-30)

    angefangen!

    0
    Aktionen für Kommentare Permalink
  • Avatar
    Oxenkopf1971

    Ich habe bei 327 Titeln nun folgendes Schnittergebnis:

    1-15(OK), 16>17 (15Sekunden), 18-33(OK), 34>35(13Sekunden), 36-41(OK), 42>43(ms)>44(ms), 45-50(OK), 51>52(ms), 53-56(OK), 57>58(ms), 59-79(OK), 80>81(14Sekunden), 82-122(OK), 127>128(ms)>129(ms), 130-135(OK), 136>137(9Sekunden)>138(ms)>139(ms), 140-158(OK), 159>160(16Sekunden), 161-171(OK), 172>173(8 Sekunden), 174-188(OK), 189>190(1Sekunde), 191-203(OK), 204>205(12Sekunden), 206-217(OK), 218>219(6Sekunden)>220(ms)>221(ms), 222-227(OK), 228>229(6Sekunden), 230-244(OK), 245-246(ms), 247-249(ok), 250>251(17Sekunden), 252-278(OK), 279>280(ms), 281-285(OK), 286>287(6Sekunden), 288(OK), 289>290(ms)>291(ms)292(ms), 293-305(OK), 306>307(16Sekunden), 308-320(OK), 321>322(6Sekunden), 323-327(OK).

    Falscher Schnitt: Der Anfang des nachfolgenden Liedes befindet sich am Ende des aktuellen Liedes, so dass das nachfolgende Lied am Anfang abgeschitten ist. Auch im ms-Bereich, was sehr störend ist.

    Aufnahme erfolgte im Wave Format, da ich die fehlerhaften Dateien zusammengefügt habe (klappt wunderbar ohne Aussetzer, also nahtlos). Und eine MP3 Datei in ein Bearbeitungsprogramm zu stecken (welches zum bearbeiten eh wieder in WAV umwandelt um es danach wieder in MP3 zu konvertieren) erscheint mir aus Qualitätsgründen Sinnlos.

    0
    Aktionen für Kommentare Permalink
  • Avatar
    woof

    Hallo, ich muss leider gestehen, durch die Diskussion hier wurde ich doch motiviert, auf die Alternativen zu schauen, die ich schon mal heraus gesucht hatte und habe doch eine offenbar in der Funktion legale gefunden, die "you only had one job" erledigt – ohne die Probleme hier und ohne 1000 Funktionen die ich eh nicht will (oder sogar für Unfug halte, wie „Original-Qualität“). Bezahlt, größere Playlist abgearbeitet und ich kann all die Probleme hier damit nicht sehen... (Oxenkopf1971: Es ist ein anderes Programm als das von Dir andeutungsweise präferierte, und bei dem ist m.E. doch Legalität wegen „aufnehmen was Spotify abspielt“ gegeben.)

    Ich begleite das hier schon viele viele Jahre, war sogar mal Moderator im Forum, aber den Support hier fand ich stets und finde ihn auch jetzt grauenhaft. Auch diese Anfrage nun wieder: Ja, ich komme aus der Softwareentwicklung und weiß wie häufig schwierig und doch notwendig Reproduzierbarkeit ist. Dennoch begleitet uns dieses Problem über viele Monate, über lange Diskussionen hier im (vorherigen) Forum und weitgehend hat der Support dazu eher geschwiegen. Hier jetzt nochmal den Standardfragen-Katalog abzuspulen zeugt nicht gerade davon, dass es euch neuerdings ernst ist...

    Aus langer Verbundenheit heraus will ich die Fragen mal weitgehend beantworten, wo sie sich von @Oxenkopf1971 unterscheiden. Wobei, ich wurde per Mail über zwei detaillierte Antworten von ihm hier unterrichtet, jetzt sind die weg...

    Grundsätzlich gab es bei mir stets eine relevante Menge von Titeln, bei denen die ersten Millisekunden, unter einer Sekunde meist, hörbar am Ende des vorherigen hingen. Zur Prüfung im Player per Extra-Einstellung zusätzliche Pausen am Titelende reinkonfiguriert, um eine Lücke hören zu können wo keine hingehört. Tatsächlich wahrnehmbar. Insb. wenn man wie ich Wert auf Qualität legt und die Titel auch nicht immer wieder in der Reihenfolge der Konvertierung hört.

    Und dann habe ich nach FLAC konvertiert, damit ich diese Fehler mit Audiacity manuell beheben kann (FLAC nutze ich schon ewig, vorher WAV, weil es früher eher mal fehlende Schnitte waren, wo zwei Stücke noch aneinander klebten).

    In Spotify habe ich alles deaktiviert, was zum Problem beitragen oder Qualität mindern könnte, Playlisten-Inhalte heruntergeladen, keine Überblendungen, keine Lautstärkenangleichung (auch weil ich mir damit den Weg zu „Album-Gain“ verbauen würde). Lautstärke in Spotify ist bei zirka 80% (so genau kann man das nicht sagen), aber inzwischen hat da ja offenbar eh keinen Einfluss mehr auf die Aufnahme (gibt ja ein extra Thema hier im Forum, gab es auch im alten), ich bin mir sicher dass das früher anders war – und da war es sehr wohl sinnvoll (anders als @Oxenkopf1971 in seinen hier wieder fehlenden Antworten schilderte), diese mittels Testaufnahmen zu wählen, um Übersteuerung zu vermeiden (ich korrigiere hinterher mit MP3Gain).

    Ich lasse die Konvertierung stets mit einer längeren über einen Zeitraum gesammelten Playliste über Nacht o.ä. laufen, d.h. es gibt keinerlei andere Aktivität parallel. Muster beim Problem kann ich nicht erkennen, weder bestimme Titel (wobei ich selten das Gleiche mehrfach konvertiere), oder Genres, oder Fades versus abruptes Ende, oder oder oder. Auch habe ich keine Besonderheiten bzgl. Ausgabeformat (habe es mal mit WAV getestet), Tagging usw. festgestellt.

    Ich habe stets von allem die aktuellsten Versionen installiert, von Audials, Tunebite und Windows 10 (64bit). Spotify selbstinstalliert, nicht aus dem Store.

    0
    Aktionen für Kommentare Permalink
  • Avatar
    audials_guy

    Hallo,

    erstmal vielen Dank @Oxenkopf1971 (deinen sehr detaillierter Bericht habe ich bekommen, auch wenn ich ihn hier nicht sehe, evtl. war er non-public oder du hast ihn rausgenommen - egal, ich habe ihn) und @woof.

    Ich habe den Eindruck dass wir möglicherweise zwei Symptome jagen - die die gleiche Ursache haben oder auch nicht. Ich fasse mal das "Wissen" zusammen.

    Vorbemerkung

    Um perfekt zu schneiden benutzt Audials mehrere Informationen. Insbesondere

    - Es berücksichtigt was der Spotify player ausgibt welches Lied er spielt (zeigt ja offenbar Liedwechsel)

    - Es arbeitet auf dem Audio-Signal, um "fein zu schneiden". (u.a. silence detection).

    Symptom 1: Grob daneben

    (Berichtet u.a. von Oxenkopf1971)

    Bei langen Playlists wird bei etwa jedem 20. bis 30. Lied eine SEHR LANGE Zeit falsch geschnitten (viele Sekunden).

    Dies dürfte weniger an der Silence-Detection liegen, die nur in einem engen Zeitfenster optimiert.

    @woof: hast du diesen Fehler auch beobachtet? (sehr viele Sekunden daneben)

    Symptom 2: Millisekundenbereich

    (berichtet sowohl von woof als auch Oxenkopf1971)

    Es sind einige ms des "nächsten Liedes" an das alte Lied "drangeklebt".
    (Je nach Art des Anfangs des neuen Liedes kann das natürlich sehr störend sein).

    Hier ist - laut messung von Oxenkopf - ca. jedes 50. Lied betroffen.

     

    @woof:
    - ist bei dir die Häufigkeit von Symptom 2 ähnlich? 
    - konntest du auch Symptom 1 beobachten?

    (ich weiss dass die Fragerei nervt... aber ich versuche möglichst viele Informationen zu sammeln, damit wir besser testen können um es eben zu reproduzieren.
    - Wir können die Tests auf "aktuelle win10 / 64 bit" Systeme beschränken
    - Wir sollten stets mindestens 100 Files/Playlist testen, um den Fehler halbwegs sicher zu haben)

    Alle weiteren "Randbedingungen" helfen uns natürlich...

    Ich melde mich falls wir etwas reproduzieren können, wir werden es versuchen

     

     

     

    0
    Aktionen für Kommentare Permalink
  • Avatar
    Starfox

    Gerne beantworte ich das:

     

    - Welche Windows-Version? Windows 10 64 bit Build 1809

    - CPU, Arbeitsspeicher? Core i7 3820 3,6GHZ , 8GB DDR3 1866 Corsair

    - herkömmliche Festplatte oder SSD? Herkömmliche HDD Western Digital Raptor SATA 3 Platte 1TB

    - Welche Spotify Version? 1.0.86.337

    - Spotify "aus Windows Store" oder "selbstinstalliert"? selbstinstalliert

    - Spotify free oder Premium? Free Version

    - Wie ist die Lautstärke von Spotify gesetzt? Maximum

    - Ist in Spotify-Einstellungen "Standardeinstellungen - gleiche Lautstärke für alle Songs festlegen" an oder aus? Gleich Lautstärke für alle Songs da die Aufnahme sonst übersteuert (anderer Forenbeitrag anderes Problem)

    Frage zu Randbedingungen des Fehlers:

    - Tritt der Fehler nur bei "High speed" auf, oder auch bei Normalgeschwindigkeit? beides

    - Tritt der Fehler immer (bei jedem Lied) auf, oder nur sporadisch? sporadisch

    - Tritt der Fehler in jeder Session (in jedem Durchgang) auf, oder nicht? Bei einer größeren Playlist oder Alben in jeder Session bei nur wenigen Songs manchmal gar nicht da nur sporadisch wie oben schon geschrieben.

    - Ist der Fehler - um wie viele Sekunden verschoben ist - dann in allen Liedern gleich, oder variiert er? Das variiert oft bei mir 1 Sek. zuviel manchmal auch mehrere Sekunden

    - Ist er vielleicht "lastabhängig", d.h. wird er häufiger wenn man auf dem PC "andere Dinge tut"? Ich habe nur Spotify und Audials offen sonst nichts und der PC wird nicht während der Aufnahme nicht weiter benutzt.

    - Hängt er vielleicht von den Lieder ab, d.h. tritt bei bestimmten Liedern immer auf? (Dann wäre natürlich super zu wissen, welches Lied) Der Fehler tritt immer wieder auf nicht nur bei bestimmten Liedern, ich habe sowohl epische Musik (Two Steps From Hell, Immediate etc.) als auch Rock oder Dubstep aufgenommen und der Fehler tritt überall sporadisch auf auf.

    - Gibt es, falls dieser Fehler auftritt, in der gleichen Session (Durchgang) auch Tagging-Fehler dass entweder "Künstler" oder "Liedname" fehlen würde oder nicht korrekt wäre? Nein selbst wenn richtig getaggt wurde ist der Fehler da.

    - Gibt es irgend etwas Sonstiges an "Umständen", die diesen Fehler auslösen oder häufiger machen? Nicht das ich wüsste.

     

    :Edit: Spotify hab ich ebenfalls wie Oxenkopf Überblendung deaktiviert und Automatische Warteschlange auch deaktiviert. Also eigentlich alles deaktiviert bis auf gleiche Lautstärke für alle Songs.

     

    Hoffe ich konnte damit helfen.

    0
    Aktionen für Kommentare Permalink
  • Avatar
    woof

    @audials_guy schrieb:

    @woof: 
    - ist bei dir die Häufigkeit von Symptom 2 ähnlich? 
    - konntest du auch Symptom 1 beobachten?

    Nur „ca. jedes 50. Lied“? Keinesfalls. Eher zwischen jedem fünften und achten. Jetzt nachträglich geschätzt, im alten Forum hatte ich das glaube ich mal genauer gesagt...

    Nein, Ungenauigkeiten um viele Sekunden habe ich nicht beobachtet.

    PS: Einfachheit des neuen Forums in allen Ehren, aber dieser Minimalismus macht vernünftige Kommunikation echt schwierig, wenn ich nicht mal zitieren kann, bzw. als Zitat kennzeichnen und so gezielt reagieren, antworten kann... Passt wieder zu meiner Beobachtung, dass an echten Support hier gar nicht gedacht ist... Mal davon abgesehen, dass sich das Forum nicht merkt, in welcher Reihenfolge ich Beiträge aufgelistet haben möchte, dass die Voreinstellung „Neuster Post“ wenig hilfreich ist und und und ...

    0
    Aktionen für Kommentare Permalink
  • Avatar
    Oxenkopf1971

    Meine Beiträge stehen alle noch auf "Wartet auf genehmigung"

    0
    Aktionen für Kommentare Permalink
  • Avatar
    Starfox

    Symptom 2 kann ich auf jedenfall bestätigen.

    Symptom 1 ehr seltener

    Hier mal noch ein Bild dazu, grün alles in Ordnung, gelb fängt er komischerweise an zwischen linke und rechte Spalte differenzen in der Songlänge zu bekommen. Rot ganz unten ist dann 1 Sek drüber siehe Spotify rechts daneben im Bild die Songlängen.

    0
    Aktionen für Kommentare Permalink
  • Avatar
    audials_guy

    Hallo,

    es scheint sehr wahrscheinlich dass wir tatsächlich ZWEI Probleme vermischen.

    Symptom 1 "sehr grob / viele Sekunden daneben"

    (bisher ausschließlich beschrieben von Oxenkopf)
    Dies ist ein Problem dass wir tatsächlich nachstellen konnten.
    Es wird ausgelöst auf schwächeren PCs und/oder hohe Systemlast, in Kombination mit "high speed Aufnahme".
    In dieser Situation gibt Spotify manchmal das Lied das es abspielt sehr stark verzögert (viele Sekunden) aus (weil der PC in diesem Moment zu ausgelastet ist).
    Das widerum bringt audials dazu, den Liedwechsel viele Sekunden zu spät zu suchen, und wenn es eine Stelle findet die nach den Audiodaten ein Liedwechsel sein könnte (aber nicht ist), dort auch zu schneiden.

    Hier können wir vermutlich recht wenig tun. Aber als Nutzer kann man es verhindern
    - Indem man sonstige Dinge auf dem PC nicht parallel laufen lässt (Virenscanning etc. Hintergrunddinge) oder arbeitet
    - Indem man ohne high speed recorded (weil es dann weniger Last erzeugt)

    Symptom 2 "einige ms falsch geschnitten"

    Dies ist das eigentliche Problem, denn hierüber berichten mit Starfox, woof, Oxenkopf gleich 3 Nutzer, mit z.T. stärkeren PCs.

    Es dürfte auch eine andere Ursache haben, denn der "Hinweis" den Spotify über das ausgegebene Lied nennt, ist ja niemals millisekundengenau.

    Auch Datenverlust kann man ausschließen, da ja die im zweitenLied fehlenden ms offenbar exakt im ersten Lied "drangeklebt" sind.

    Daher vermute ich, dass es ein Fehler in der Silence-Detection gibt, welche dazu führt dass die Feinjustierung des Schnittpunktes falsch geschieht.

    => Den wollen wir uns bemühen zu reproduzieren.

    Eine wichtige Frage dazu daher:

    Falls man den gleichen Liedübergang ein zweites Mal aufnimmt,
    also beide betroffenen Lieder nacheinander abspielt (einfach das erste betroffene Lied der Playlist in spotify abspielen, warten bis dieses und das nächste komplett gespielt wurden, dabei mit Audials high-speed aufnehmen)

    tritt es dann genauso wieder auf?

    - Falls ja, läge es "am audio dieses Liedüberganges". Dann könnten wir es nachstellen, wenn wir genau diese Lieder spielen würden

    - Falls nein, wäre es etwas "durch was anderes ausgelöstes".

    Nachtrag: Liedlängen-Anzeige
    In der linken Seite wird die Liedlänge direkt bei der Aufnahme angezeigt. Hier hat Audials die Daten als Waveform, und berechnet die Länge daraus.
    In der rechten Seite werden die fertigen Dateien (z.b. flac) angezeigt. Hier wird die Länge vom Flac-Codec berechnet.
    Beide Wege die Länge auszurechnen könnten anders auf- und abrunden, was zu Abweichungen von 1sec führen kann.
    Das dürfte daher eher nicht mit dem gesuchten Fehler zu tun haben.

     

     

    0
    Aktionen für Kommentare Permalink
  • Avatar
    Oxenkopf1971

    Aber wie kann es denn sein, dass ein System auf einmal innerhalb einer Softwareversion eines Programmes zu leistungsschwach werden kann? Vor dem von mir hier angegebenen Streaming Service Update hat doch alles reibungslos funktioniert.

    Wir erinnern uns: Es war der Wunsch des taggings der Albennamen welcher mit diesem Streaming Service eingeführt wurde. Bei der Einführung gab es die ersten klagen (auch bei mir war jeder zweite Titel "verschnitten"), dass Audials nicht mehr richtig schneidet. Ihr hattet dann festgestellt, dass das öffenen der Warteschlange und das Auslesen der Angaben durch Audials zu hohe Last verursacht und hattet dann nachgebessert. Leider hat die Nachbesserung bei mir nicht 100% eingeschlagen und diese Symptome sind nun bei mir übrig. Das ganze geht schon seit ende Oktober so.

    Achja..die Last beläuft sich bei einer Aufnahme zwischen 25 und 35%...bei LIedwechsel ist die Auslastung bis zu 75%...wenn ich das soweit richtig beobachtet habe.

    0
    Aktionen für Kommentare Permalink
  • Avatar
    Starfox
    Nachtrag: Liedlängen-Anzeige
    In der linken Seite wird die Liedlänge direkt bei der Aufnahme angezeigt. Hier hat Audials die Daten als Waveform, und berechnet die Länge daraus.
    In der rechten Seite werden die fertigen Dateien (z.b. flac) angezeigt.
    Hier wird die Länge vom Flac-Codec berechnet.

    Beide Wege die Länge auszurechnen könnten anders auf- und abrunden,
    was zu Abweichungen von 1sec führen kann.

    Das dürfte daher eher nicht mit dem gesuchten Fehler zu tun haben.

    Ok verstehe ich, aber trotzdem tritt Symptom 2 "der ms falsch Schnitt" sporadisch auf.

    Das Symptom 1 tritt bei mir persönlich extrem selten auf.

     

    Falls man den gleichen Liedübergang ein zweites Mal
    aufnimmt, also beide betroffenen Lieder nacheinander
    abspielt (einfach das erste betroffene Lied der Playlist
    in spotify abspielen, warten bis dieses und das nächste
    komplett gespielt wurden, dabei mit Audials high-speed
    aufnehmen)

    tritt es dann genauso wieder auf?

    Ja es tritt genauso auf aber nicht immer manchmal wird es dann auch richtig geschnitten. Ist auch wieder 50/50 die Chance das es richtig geschnitten wird.

     

    :Edit: hab oben meine Spotify Version reingeschrieben hatte versehentlich die Audials Version gepostet. (1.0.86.337)

    0
    Aktionen für Kommentare Permalink
  • Avatar
    audials_guy

    Thema "einige MS falsch geschnitten"

    (@Starfox, @woof)

    Sorry dass ich nochmal nachhake, da wir dieses spezielle Problem sehr gerne nachstellen (um es zu lösen) würden:
    D

    Die entscheidende Frage ist, ob "einige MS falsch geschnitten" (hatte es Symptom 2 genannt) bei Wiederholung immer gleich auftritt.
    Um das zu testen reicht es nicht, eines der Lieder nochmal aufzunehmen.

    Man müsste beide Lieder direkt hintereinander spielen. Wenn ihr das tut, tritt dann der "falsche Schnitt" immer genauso wieder auf, oder nicht?

    Das ist für uns um es nachzustellen und dann zu verbessern ziemlich entscheidend. 

    - Entweder es wird ausgelöst von einer Abfolge zweier bestimmter Lieder. => Dann könnten wir es sofort nachstellen wenn wir exakt diese beiden Lieder wüssten.

    - Oder es wird ausgelöst durch etwas anderes, "Zufälliges". => Dann könnten wir ausschließen dass der Fehler im Silence-Detection-Algorithmus an sich liegt.

    Daher falls es nicht zu viel Mühe macht genau zwei betroffene Lieder mehrfach zu testen, das zu wissen würde sehr helfen.
    (Ich würde ja auch wirklich gerne selbst nachgucken, bekomme diesen Fehler aber einfach nicht)

     

    Thema "Etliche Sekunden daneben" (@Oxenkopf)

    In der Tat hatten wir im Herbst wegen einer anderen Verbesserung (Warteschlange) die Performance-Anforderungen ungewollt erhöht und dann wieder gesenkt, etliche Nutzer haben bestätigt dass es danach nicht mehr auftrat. Es ist schade dass es offenbar auf deinem PC immer noch nicht "gut genug für high-speed" optimiert wurde.

    Da wir hier ziemlich genau wissen, "um welche Ecke" es hier geht (Spotify-Performance muss reichen damit Spotify Liedwechsel nicht zu spät anzeigt), werde ich mal weitergeben ob die Programmierer nochmal versuchen können es weiter zu optimieren.

     

    0
    Aktionen für Kommentare Permalink
  • Avatar
    Oxenkopf1971

    @audials_guy Danke für die Info, ganz befriedigt mich diese Aussage allerdings nicht und zwar aus folgendem Grund! Sollte tatsächlich ein Performanceproblem meinerseits vorliegen (Spotify aufnahme in MP3 direkt), warum tritt dann das Problem auch bei Aufnahme in WAVE Dateien auf und zwar in gleichem Schema? Ich bin der Meinung, das die Aufnahme und das anschließende umwandeln in MP3 in einer Session mehr LAST verursacht wie die reine Aufnahme in WAVE. Das System hat hier ja wesentlich weniger zu tun, lediglich das Schneiden der Originalaufnahme und dann das kopieren in den Zielordner! Das selbige gilt für das Auslagern des Zielordners auf ein externes Medium (USB3, Festplatte kein Stick). Auch hier wird nochmals die Last reduziert (meiner Meinung nach). Aber es ist egal, welche Konfiguration ich Wähle (Direkt auf HDD oder Extern, WAVE oder MP3 in verschiedenen Kombinationen), das Ergebnis ist immer selbiges.

    Ich werde heute abend einmal die Titel im Ms-Bereich nochmals nach Anweisung aufnehmen (hab ja genug davon) und es dann mitteilen, was dabei herrauskam.

    0
    Aktionen für Kommentare Permalink
  • Avatar
    audials_guy

    Hallo Oxenkopf, 

    nun es ist alles natürlich nur Spekulation meinerseits...
    Es geht weniger um die Systemlast ingesamt. Das Problem wird dadurch ausgelöst, dass Spotify das aktuelle Lied unter gewissen Umständen (eben manchmal bei dir, aber auch sporadisch auf einem unserer schwächeren Test-PCs) verspätet als Text auf der Nuzteroberfläche ausgibt bzw. audials es zu spät liest. Daher sucht Audials den Schnittpunkt offenbar viele Sekunden zu spät (denn dank highspeed verfünffacht sich der Fehler).

    Ausgelöst wird das offenbar nicht durch mp3-Encoding und nicht durch Festplattenzugriff, wie du beschreibst.

    Ich denke eher dass es damit zu tun hat, wie Audials die Spotify-Nutzeroberfläche beobachtet, denn du hast ja berichtet dass es schlechter wurde in dem Moment wo wir die Playqueue (für album-Tags) gelesen haben.

     

     

    0
    Aktionen für Kommentare Permalink
  • Avatar
    JackON

    Hallo,

     

    also ich hab jetzt mal getestet.

    Im normalen Modus wurden jetzt von 23 Liedern ACHT falsch geschnitten.

    Die erste Sekunde des nächsten Liedes hängt hinten dran.

    Ganz egal welches System ich nutze. i5 Laptop, i5 PC und i7 PC.

    Alle Windows 10 Pro und überall die neueste Audials One 2019 Version. Windows 10 1809 mit allen Updates.

     

    Im Highspeed Modus gehen teilweise 15 bis 20 Sekunden daneben.

     

    Also ich behaupte es liegt nicht an unseren Systemen.

    Mit Ausials One 2018 gings ja auch. Und das hab ich noch auf einen anderen i7 System laufenl. Und es läuft!

    0
    Aktionen für Kommentare Permalink
  • Avatar
    audials_guy

    Oh!

    Du bist der zweite (nach Oxenkopf) der dieses Symptom (viele Sekunden falsch geschnitten) berichtet. Und das auf mehreren, auch schnellen PCs!

    Was auch erstaunlich ist: Audials One 2018 benutzt grundsätzlich die gleiche, von uns regelmäßig geupdatete Komponente um aufzunehmen. Und trotzdem funktioniert es immer noch!

    Ich muss zugeben, ich kann mir im Moment nicht erklären wie das zustande kommt. Aber es ist eine "interessante Spur". Hast du es wirklich auf allen genannten PCs in gleicher Weise gesehen?
    Und gibt es sonst irgendetwas "Besonderes?" Vielleicht irgendeine Einstellung in Spotify bezüglich der Wiedergabe? Nutzt du "Spotify connect?"

     

    0
    Aktionen für Kommentare Permalink

Bitte melden Sie sich an, um einen Kommentar zu hinterlassen.