5.1 Surround and 1080p Netflix Audials 2022

Kommentare

50 Kommentare

  • Avatar
    mbarylski

    Denisa Aleman It's been 2 weeks, can you please provide an explanation?

    0
    Aktionen für Kommentare Permalink
  • Avatar
    TRKarimman

    Ok It starts getting interesting...

    I am ripping The Witcher Season 2 right now and look at this. 5.1 ripped with the help of my tutorial. I used Google Chrome. This shouldn't be possible but it is. I am confused right now. So happy Ripping y'all

    Edit: My older Rips are actually only 2 Channels in 5.1. Maybe Chrome allowed 5.1 Audio because my new headset has virtual 7.1 support. I also double checked my newer rips and yes these are 6 different Channels and not 6 same.

    0
    Aktionen für Kommentare Permalink
  • Avatar
    popeye0815

    TRKarimman which tool did you use to see the audio channels of the recorded video?

    0
    Aktionen für Kommentare Permalink
  • Avatar
    popeye0815

    Enabling 5.1 Audio in Netflix works for me with the built-in Audials feature without the Chrome extension. I also recorded with an ouput format profile with surround sound. MediaInfo shows 6 channels of the resulting recorded file. However, every channel but left and right are silent. 

    I checked the Log-File and found an interesting ffmpeg parameter setting: 

    2022-01-02 22:26:54,971 [10756] DEBUG - |Detail| ffmpeg parameters: -f s16le -ac 2 -ar 48000 -i "\\.\pipe\input_20220102_222654_908" -vn -c:a aac -ar 48000 -ac 6 -b:a 320k -c:v libx265 -s 320x240 -preset medium -x265-params crf=17 -r 25.00 -y "C:\Users\XYZ\AppData\Local\Temp\RapidSolution\ConvertFiles\.recording\20220102_222654_775-audio.m4a"

    Question: How should it be possible to record 5.1 sound, if Audials sets the number of audio channels of the input source file to 2 (bold -ac 2)?!? Doesn't this parameter mean, that even if the input source file (the recorded 5.1 netflix file) has 5.1 channels, that these are down-mixed again to 2 channels?

    If so, is there any way in the command line of a custom profile, to get rid of this input parameter?

    0
    Aktionen für Kommentare Permalink
  • Avatar
    mbarylski

    toxiccrack Thanks for the tip, I'll have to try that. Are the 6 channels all distinct channels? Anytime I've tried it in the past it's just the stereo channels replicated to all 6 channels.

    0
    Aktionen für Kommentare Permalink
  • Avatar
    toxiccrack

    mbarylski yes, they are all distinct (you can see that in the screenshot). BTW I tested it with Hacksaw Ridge.

    0
    Aktionen für Kommentare Permalink
  • Avatar
    mbarylski

    @toxiccrack Awesome! I'll definitely give it a shot. Thanks!

    0
    Aktionen für Kommentare Permalink
  • Avatar
    popeye0815

    thanks for this hint! IMHO, Audials MUST make a system requirement notice if 5.1 recording is only possible with a 5.1 sound card, otherwise it‘s false advertising!
    Therefore, Audials should asap fix this problem in order that every customer, with only a stereo sound card, can record 5.1 sound!

    Cheers!

    0
    Aktionen für Kommentare Permalink
  • Avatar
    popeye0815

    Folks!
    Meanwhile I also can confirm that 5.1 recording works if you have a 5.1 sound card. I‘ve bought an external 5.1 USB sound card and there it is - 6 channels each with a different signal. Before there were 6 channels recorded but only stereo channels had sound (cf. my previous post).
    I‘ve also checked the log-file and my assumption was confirmed: with a stereo card, Audials sets the ffmpeg input parameter -ac 2, which Leads ALWAYS to a 2.0 downmix.
    With the 5.1 sound card connected, the parameter was set to -ac 6.

    Cheers

    0
    Aktionen für Kommentare Permalink
  • Avatar
    Faxe36

    Hello, I also bought an external sound card.
    Yes, there were 6 channels recorded. But as before there is an extreme poor sound quality.
    I tried many different settings but always with an awful result.
    Can anybody tell me what I did wrong?
    (using a windows surface laptop).
    Thanks a lot in advance.

    0
    Aktionen für Kommentare Permalink
  • Avatar
    popeye0815

    Forget the predefined profiles. They all use AAC as audio codec with 128 kbps, even for ALL 6 channels. Therefore each channel only has 128/6 = 21,3 kbps, which is far too low.
    Create your own custom profile and increase the Bitrate to 320 kbps.
    Or even better, use the command line argument text field and use a better audio codec.
    I‘m using AC3 with 640 kbps, which encodes the source with transparent quality.
    The command line arguments for this are:
    -c:a ac3 -ac 6 -b:a 640k

    Cheers!

    0
    Aktionen für Kommentare Permalink
  • Avatar
    toxiccrack

    Thanks, popeye0815 I will definitely try that! I too wondered why the sound is so bad :D

    0
    Aktionen für Kommentare Permalink
  • Avatar
    Faxe36

    Thank you very much popeye0815 !
    I will also try it.

    0
    Aktionen für Kommentare Permalink
  • Avatar
    Faxe36

    Dear popeye0815 sounds better when I increase the Bitrate to 320.
    Unfortunately I get an "Error" after recording with a Profile using the command line argument
    -c:a ac3 -ac 6 -b:a 640k
    Any suggestions?

    0
    Aktionen für Kommentare Permalink
  • Avatar
    popeye0815

    @Faxe36:
    yes, sorry I‘ve omitted the necessity that you also need to pass arguments for the used video codec. It depends how you want to encode the video. H.264/H.265 with/without GPU acceleration.
    If you want the same settings used by a profile you can do the following:
    1. Choose a predefined profile of your choice which uses your preferred video codec
    2. Enable Enhanced Logging in the Audials settings
    2.1 open that directory

    3. Start a sample recording

    4. Look into the log-file “EncodingBackend.log”
    4.1 Search for the term “ffmpeg parameters”

    5. Look for the one which contains -an in the command line.

    6. Copy the video codec specific command line arguments and paste them in your custom profile command line arguments text field followed by the audio codec parameters posted before.

    Cheers.

    0
    Aktionen für Kommentare Permalink
  • Avatar
    Faxe36

    Dear Popeye0815.
    Thanks a lot.
    Till now I did not manage it. Still trying but always getting an error. I will go on. This should work.

    0
    Aktionen für Kommentare Permalink
  • Avatar
    popeye0815

    To make it easier, in the following you find my command line arguments. 

    video codec: HEVC (H.265) Intel iGPU accelerated
    preset slow: trade-off between quality/performance; slower == better quality
    global_quality 18: ensures perceptual visual video quality equal to source (the value can vary dependent on source material; typically a value between 22 and 18 yields moderate to non-noticeable quality loss)

    audio codec: ac3
    ac 6: 6 channels
    bitrate: 640k

    -c:v hevc_qsv -load_plugin hevc_hw -preset slow -global_quality 18 -c:a ac3 -ac 6 -b:a 640k
    0
    Aktionen für Kommentare Permalink
  • Avatar
    Faxe36

    Hi Popeye0815
    works great! Thank you very much for your kind support.

    0
    Aktionen für Kommentare Permalink
  • Avatar
    JonathanTreffler

    @popeye0815 Your method alone didn't work for me, but I installed VB Audio CABLE and configured it to 5.1 sound. Recording with the virtual sound card selected as the primary sound device in windows using the default surround profile worked but sounded bad (because of the low bitrate) but in combination with the parameters determined by your method the results are great :)

    0
    Aktionen für Kommentare Permalink
  • -1
    Aktionen für Kommentare Permalink

Bitte melden Sie sich an, um einen Kommentar zu hinterlassen.